You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

33 lines
996B

  1. # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
  2. # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
  3. # Contributor: Thomas Dziedzic < gostrc at gmail >
  4. # Contributor: Bert Muennich <muennich at informatik.hu-berlin.de>
  5. # Contributor: Brad Fanella <bradfanella@archlinux.us>
  6. pkgname=sxiv
  7. pkgver=26
  8. pkgrel=1
  9. pkgdesc='Simple X Image Viewer'
  10. arch=('x86_64')
  11. license=('GPL2')
  12. url='https://github.com/muennich/sxiv'
  13. depends=('imlib2' 'desktop-file-utils' 'xdg-utils' 'hicolor-icon-theme' 'libexif' 'libxft')
  14. source=("$pkgname-$pkgver.tar.gz"::"https://github.com/muennich/sxiv/archive/v$pkgver.tar.gz" "config.h")
  15. md5sums=('969d086bff438ae882433f8729d2b95d' 'SKIP')
  16. prepare() {
  17. cd "$pkgname-$pkgver"
  18. cp ../config.h .
  19. }
  20. build() {
  21. make -C "$pkgname-$pkgver"
  22. }
  23. package() {
  24. cd "$pkgname-$pkgver"
  25. make PREFIX=/usr DESTDIR="$pkgdir" install
  26. make -C icon PREFIX=/usr DESTDIR="$pkgdir" install
  27. install -Dm644 sxiv.desktop "$pkgdir"/usr/share/applications/sxiv.desktop
  28. }